ΑΣΚΗΣΕΙΣ ΜΕ ΠΙΝΑΚΕΣ ΤΙΜΩΝ

 

 

 ΑΣΚΗΣΕΙΣ  ΜΕ  ΠΙΝΑΚΕΣ  ΤΙΜΩΝ
  1. Να σχεδιάσετε τον πίνακα τιμών και τις τιμές που θα εμφανιστούν στην οθόνη μετά την εκτέλεση του παρακάτω τμήματος προγράμματος:

                    Αρχή

                x ← 13

                y ← 21

               Όσο x < 27 επανάλαβε

                         y ← y + 2*x - 24

                        z ← y div x

                        Αν z mod 2 = 0 τότε

                                   x ← x + 2

                       αλλιώς

                                 y ← y + 3

                     Τέλος_αν

                    Γράψε x, y

                    x← x + 3

            Τέλος_επανάληψης

             Γράψε x, y

 

  1. Να βρείτε τις τιμές των μεταβλητών Χ, Α, Β σε κάθε επανάληψη.

                 Αρχή

                 Χ ← αληθής

                 Β ←1

                 Αρχή_επανάληψης

                        Α ← Β * 3

                       Αν Α >= 9 τότε

                               X ← ψευδής

                      Τέλος_αν

                       Β ← Β + 1

               Μέχρις_ότου Χ = ψευδής και Β > 4

 

  1. Nα βρείτε τις τιμές των μεταβλητών Α, Β, C, D, X και Υ σε όλες τις επαναλήψεις.

              Για Χ από 2 μέχρι 5 με βήμα 2

                        Α ← 10*Χ

                        Β ← 5*Χ + 10

                        C ← A+B-(5*Χ)

                        D ← 3*Α-5

                        Y ← A+B-C+D

            Τέλος_επανάληψης

  • Δημιουργήθηκε στις
  • Τελευταία ενημέρωση στις
  • Προβολές: 199

Σύνδεση

Εισάγετε το όνομα χρήστη και το συνθηματικό. Μόνο οι διδάσκοντες έχουν πρόσβαση.